Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Unfortunately the software that I'm using (Alfresco) requires the installation of openoffice, and not libreoffice. If I try and configure it to use libreoffice I receive errors during startup. If I try to install any of the openoffice packages:

yum install openoffice*

I receive errors for all packages similar to:

Package is obsoleted by libreoffice-langpack-bg, trying to install 1:libreoffice-langpack-bg- instead

Then it proceeds to try and download libreoffice. I don't see anything in man yum with regards to installing obsolete packages. Is there any way to install obsolete packages via yum and not their newer counterparts?

share|improve this question
same problem installing languageweaver. @BengiWiebe below solved my problem perfectly. – MattPark May 29 '13 at 18:18
up vote 0 down vote accepted

If you prefer, you can download the proper package (deb, rpm..) from the official website:

After you can install with rpm or with yum.

share|improve this answer

I found that, when installing openoffice, adding exclude=libreoffice* to your /etc/yum.conf helped with sudo yum update, and I am sure that it would help with your problem too. It tells yum to ignore libreoffice* packages, therefore yum does not even know that there is a package that obsoletes openoffice.

share|improve this answer
Best solution because you don't have to download anything manually. Also you don't have to yum clean all and rebuild the cache in case you were wondering. – MattPark May 29 '13 at 18:20
Important to note that if it's a single command you are running (e.g. in a script), you don't need to mess around with yum.conf—you can just use --exclude=libreoffice\* as a flag to yum directly on the command line. – Wildcard Feb 1 at 22:28
sudo yum --setopt=obsoletes=0 install openoffice*

Or you can put obsoletes=0 to /etc/yum.conf

Both ways worked for me on Oracle Linux 6.7.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.