Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to run a reverse proxy through to a website running locally through IIS to get SSL functioning. I've got all my rules set up so that I can see 90% of the site perfectly. The application is Atlassian's Crucible, but I think my issue is more generic than that.

The bad request has the following format (with sanitized names and paths)

https://bar.foo.com/crucible/cru/CR-4/edit-changelog/~author%3Dtheauthor%2520%253Ctheauthor%254040foo.com%253E/repository/

It appears that the URL re-write is dropping everything after the ~ character in the request.

For my inbound rewrite rule I've tried

crucible(.*)
^crucible(.*)
^/crucible(.*)
^/crucible(.*)$

And about a dozen other variations. I've also done this with the 'apply query string' box both checked and unchecked.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

I've finally figured out a way to get the application to work correctly. The correct UR is

crucible(.*)(~.*)?

Then I pass the URL to my site with a suffix of

{R:1}{R:2}

And it now works.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.