Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have just come across a truly bizarre problem. My company has USB-based card swipers for reading credit cards. Swipe a card, and it reads it as keyboard input. Nice and simple. We can open Notepad and swipe a card, and get data that looks like:

%B6034********9062^LYNK GIFT CARD^1812120000****1000?;6034********9062=1812120000****1?

(with actual numbers for the *'s, and this is a random gift card I have laying around, but the principle's true for credit cards too)

Our users use Windows Remote Desktop to get to the server where the software that charges the card lives. When the RD window is not full screen, everything works as expected. But when it is maximized, this is the input that shows up when that card is swiped :

5b6034********90626lynk gift card61812120000****1000/;6034********9062=1812120000****1/

All capitals became lower case, %'s became 5's, and so on. Basically, everything is losing the shift key.

This only happens when swiping into a maximized remote desktop window. If it's not maximized, or if it's maximized but you're swiping into a local app, then it behaves normally. Regular keyboard input works normally, however.

share|improve this question
Warning: The type of card reader I discuss above is not PCI-compliant, and can make you liable in case of a data breach. – Bobson Jul 17 '15 at 16:47
up vote 2 down vote accepted

As I was writing the question, I realized that it was the shift key not being picked up (as I mentioned above), and searching for that led me to find this which explained how to fix it.

After some experimenting, I found that changing asetting in the nested (Microsoft OS based) Remote Desktop Connection client cured this. The setting is on the “Local Resource” under the “Keyboard” section and is called “Apply Windows key combinations (for example ALT+TAB)”. This needs to be changed from the default (In full screen mode only) to “On the local computer” (don’t forget to save the connection settings).

share|improve this answer
I feel weird answering my own question, but since I solved it because I was asking it, I figured I'd share. Yay for talking to the duck‌​. – Bobson Jul 19 '12 at 21:46
Thanks so much for this, this solved our issue as well, really strange. – Adam Jul 17 '15 at 16:43
@Adam - Glad it helped. If you're actually using swipers (rather than just having shift key issues), keep in mind the warning I just added to the question's comments. Anything that gives you raw swipe data is not safe to have around. – Bobson Jul 17 '15 at 16:49

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.