Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to build apache with mod_deflate enabled. When restarting apache I'm presented with the following error:

httpd: Syntax error on line 36 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/apache/modules/ into server: /usr/local/apache/modules/ cannot open shared object file: No such file or directory

How can I get

share|improve this question
up vote 3 down vote accepted

It looks like you compiled Apache yourself, but you didn't choose to use the mod_deflate module. You'll need to recompile it, and this time enable mod_deflate.

./configure --enable-deflate ...the rest of your options...
share|improve this answer

I guess when you compiled apache you forgot to include mod_deflate. So if you decide to recompile everything again just add --enable-deflate.

Another option is compile the module as a dynamic shared object (DSO) in the current apache. Have a look at this blog post.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.