Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The server is a CentOS 5 install running Dovecot for imap access within an office LAN to about 5 computers using Thunderbird. There's only one mailbox, in the Maildir format, and about 20GB in size. One of the drives in the RAID 1 array failed recently and had to be replaced and re-synced.

Now, users are reporting strange IMAP issues from their mail clients, such as messages missing, deleted, or moved from folders.

How can I diagnose what the problem is? I haven't been able to replicate the problem myself and all I have is anecdotal evidence. It would be too easy to blame user error!

share|improve this question
    
Sorry, having a bad day... somehow missed the title when reading your question. So I'm going to add it into your question so I can reverse my downvote. –  HopelessN00b Jul 20 '12 at 2:46

2 Answers 2

Your biggest clue would be that the messages that have moved from folders are in folders they were in a while ago, but were since moved, and the missing messages are all newer messages. If that is the case, chances are that your RAID1 array actually failed a while back (stopped syncing) and when the one drive actually failed the bad-copy came live and had a bunch of old data on it.

You're not going to reproduce this with your own stuff as it's a single point-in-time thing rather than an ongoing one; you'll either see it or you don't. In the absence of any Dovecot-specific logs that may shed light on it, you're stuck with the detective work of working with your users to reconstruct more precisely what is missing/moved and attempt to derive a pattern from it. One possible pattern is presented above.

share|improve this answer

Thanks for the reply and explanation. Unfortunately, the problem seems to be ongoing and not tied to a past sync image.

Further inquiries with the staff and some trial and error shows that on several of the Thunderbird clients, messages saved to the draft folder do not appear to Thunderbird on another workstation. Or Thunderbird hangs while attempting to save a message to the drafts folder.

Apparently there is also some LAN network issues also as users reported slow-downs connecting to external sites or other network resources.

So at this point I believe the problem is two-fold: faulty cache/search data for Thunderbird, and a failing router. Haven't been able to test either solution yet, but I don't believe that the IMAP server itself is at fault.

Unless the Maildir itself did get garbled in the sync somehow!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.