Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a development and a production server, both running CentOS, on the same network with similar configurations. On one (the production server), when I do a curl, it attempts IPv6 first, but that times out after around 45 seconds and falls back to IPv4, which works fine. Ping6 also times out and never receives any packets back, but regular ping (which I think goes over IPv4) works fine. On the development server, ping6 and curl both work fine, and both use IPv6. Can anyone suggest how I might go about trying to figure out what's wrong? I'm not really a sysadmin, but I have to diagnose and fix the problem myself.

share|improve this question
    
ping is only useful to tell you that a problem might exist. If a ping fail you should almost always immediately follow that up with running a traceroute which should tell you where is it failing. –  Zoredache Jul 20 '12 at 1:29
    
Thank you! I did the traceroute on the production server, and after the first line, which had an IPv6 address, I got 29 lines of * * *. Does that mean the server isn't able to resolve the domain name? –  Dave Shepard Jul 23 '12 at 1:43

2 Answers 2

Keyword here is "Similar configurations". As opposed to "identical configurations".

I'm not trying to dumb this down, but you just need to start poking through each system's configuration files and find where they differ. Start with networking config which, on RHEL derivatives, is stored in /etc/sysconfig/network if I recall. DNS name resolution is another place to check: /etc/resolv.conf

share|improve this answer
1  
Second the DNS resolution suggestion. 45 seconds sounds suspiciously like a network timeout period. Such as would come from not having an available IPv6 nameserver configured. –  HopelessN00b Jul 20 '12 at 2:04
    
Thank you! I've tried duplicating the production server's configuration in both those files on the dev server (the faster one), but I can't make it run as slowly as the production server. I restarted the network service, which should reboot it, right? (and please don't worry about sounding like you're dumbing it down--I'm a programmer, not a sysadmin, so I need this stuff explained to me.) –  Dave Shepard Jul 23 '12 at 1:40
up vote 1 down vote accepted

Sorry to answer my own question, but we finally figured it out. IPv6 was disabled on the subnet the server was on. Enabling it fixed it. Thanks to Zoredache, ErikA, and HopelessN00b for helping me diagnose the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.