Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We are in the process of creating our own custom AMI from scratch; however, we keep encountering the following error:

root  (hd0)

 Filesystem type is ext2fs, using whole disk

kernel  /boot/vmlinuz-3.2.0-0.bpo.2-amd64 root=/dev/sda1 ro 

initrd  /boot/initrd.img-3.2.0-0.bpo.2-amd64

block error -1 for op 0


Error 3: Bad or corrupt data while decompressing file

Searches have so far proved fruitless and a couple different variants of the basic image have been tried with effectively the same error. Right now the image is stripped down to just the /boot directory with kernels, and the /boot/grub/menu.lst file.

The disk image was created as follows:

  1. Create a Xen disk image via dd
  2. Create /boot/grub
  3. Copy a working menu.lst to /boot/grub
  4. Copy the relevant kernel images to /boot
  5. Upload disk image to Amazon
  6. Register as an AMI
  7. Attempt to boot the image

The disk image was created using Xen and we are using kernel aki-88aa75e1 for the boot.

share|improve this question
    
What exact steps are you using to create the AMI? The more detail you provide by editing the question above, the more likely somebody will be able to help you. –  Eric Hammond Jul 20 '12 at 20:22
    
@EricHammond - Updated things, but this really was just trying to get the kernel to start without anything else being involved. –  rob Jul 23 '12 at 19:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.