Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am attempting to upgrade my Linux kernel to 3.2 on my Debian server. I have installed the image package, but even after rebooting I still seem to have my old 2.6 kernel. I am assuming I probably have to do something else to get it to work, could someone help with this?

root@myserver:~# uname -r
2.6.32-308.el5.028stab099.3
root@myserver:~# cat /etc/debian_version
wheezy/sid
root@myserver:~# apt-cache search linux-image
alsa-base - ALSA driver configuration files
linux-headers-3.2.0-3-amd64 - Header files for Linux 3.2.0-3-amd64
linux-headers-3.2.0-3-rt-amd64 - Header files for Linux 3.2.0-3-rt-amd64
linux-image-3.2.0-3-amd64 - Linux 3.2 for 64-bit PCs
linux-image-3.2.0-3-amd64-dbg - Debugging infos for Linux 3.2.0-3-amd64
linux-image-3.2.0-3-rt-amd64 - Linux 3.2 for 64-bit PCs, PREEMPT_RT
linux-image-3.2.0-3-rt-amd64-dbg - Debugging infos for Linux 3.2.0-3-rt-amd64
linux-image-2.6-amd64 - Linux for 64-bit PCs (dummy package)
linux-image-amd64 - Linux for 64-bit PCs (meta-package)
linux-image-rt-amd64 - Linux for 64-bit PCs (meta-package), PREEMPT_RT
nvidia-kernel-3.2.0-3-amd64 - NVIDIA binary kernel module for Linux 3.2.0-3-amd64
nvidia-kernel-3.2.0-3-rt-amd64 - NVIDIA binary kernel module for Linux 3.2.0-3-rt-amd64
linux-image-2.6.32-5-amd64 - Linux 2.6.32 for 64-bit PCs
root@myserver:~# apt-get install linux-image-3.2.0-3-amd64
Reading package lists... Done
Building dependency tree
Reading state information... Done
linux-image-3.2.0-3-amd64 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@myserver:~#
share|improve this question

1 Answer 1

2.6.32-308.el5.028stab099.3

The el5 is a bit of a giveaway that this isn't a "normal" Debian system, since el5 implies that it's some kind of RHEL derivative. Seems that that kernel is an OpenVZ container kernel, which is probably what your provider is using - in which case, you don't control what kernel you run.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.