Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Just provisioned a new Rackspace instance with Ubuntu 12.04 and pulled down rbenv from their github and installed it.

I'm getting the following errors when executing . ./~bashrc

$ . ~/.bashrc
sh: 18: /home/deployer/.bashrc: shopt: not found
sh: 26: /home/deployer/.bashrc: shopt: not found
sh: 110: /home/deployer/.bashrc: shopt: not found
sh: 28: /etc/bash_completion: [[: not found
sh: 34: /etc/bash_completion: [[: not found
sh: 51: /etc/bash_completion: Bad substitution

Here is my .bashrc (for user deployer), the only thing I added was the rbenv bit at the top.

$ cat .bashrc
# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

if [ -d "${RBENV_ROOT}" ]; then
  export PATH="${RBENV_ROOT}/bin:${PATH}"
  eval "$(rbenv init -)"
fi

# If not running interactively, don't do anything
[ -z "$PS1" ] && return

# don't put duplicate lines or lines starting with space in the history.
# See bash(1) for more options
HISTCONTROL=ignoreboth

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# If set, the pattern "**" used in a pathname expansion context will
# match all files and zero or more directories and subdirectories.
#shopt -s globstar

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "$debian_chroot" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
    # We have color support; assume it's compliant with Ecma-48
    # (ISO/IEC-6429). (Lack of such support is extremely rare, and such
    # a case would tend to support setf rather than setaf.)
    color_prompt=yes
    else
    color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
    ;;
*)
    ;;
esac

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    alias grep='grep --color=auto'
    alias fgrep='fgrep --color=auto'
    alias egrep='egrep --color=auto'
fi

# some more ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'

# Add an "alert" alias for long running commands.  Use like so:
#   sleep 10; alert
alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
    . ~/.bash_aliases
fi

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if [ -f /etc/bash_completion ] && ! shopt -oq posix; then
    . /etc/bash_completion
fi

Update:

Tests asked for in comments:

$ echo $SHELL
/bin/sh
$  /bin/sh -c 'echo $SHELL'
/bin/sh
$ cat /proc/$$/cmdline
sh
share|improve this question
1  
Are you actually running bash as your shell? –  womble Jul 22 '12 at 5:14
    
Agree with @womble. Even the error messages say sh. What does cat /proc/$$/cmdline show? –  glenn jackman Jul 22 '12 at 5:35
    
Or even echo $SHELL... –  womble Jul 22 '12 at 5:36
    
I find that's not always accurate (may depend on one's rc files). From bash, try /bin/sh -c 'echo $SHELL' -- for me that returns "/bin/bash" even though my /bin/sh is a symlink to dash. –  glenn jackman Jul 22 '12 at 5:41
    
@glennjackman I added the results of those commands in the question. All seem to point sh. How can I get bash? –  Chris Jul 23 '12 at 2:45

2 Answers 2

up vote 3 down vote accepted

The output you just posted indicates that you aren't actually running bash. This is why you are getting errors sourcing .bashrc.

To fix this problem, you need to check your login shell to make sure it's actually set to bash:

chsh -l

will list the available shells, and

chsh -s /path/to/bash

will change your login shell to bash.

Then logout and log back in.

share|improve this answer
1  
chsh -l gives chsh: invalid option -- 'l' –  Chris Jul 23 '12 at 3:15
    
well I checked on root for the path (/bin/bash) and it's all good now. Thanks for the help! –  Chris Jul 23 '12 at 3:16

shopt is a bash builtin, not a standalone executable, so source won't work. That's why you're getting that error. What are you trying to accomplish?

share|improve this answer
    
I didn't write that part. I just need to add the first couple of executable lines about RBENV so that it can run in non-interactive mode (since the [ -z "$PS1" ] && return) will stop that from happening –  Chris Jul 22 '12 at 4:02
    
Also by source I am doing . ~/.bashrc, will fix in question –  Chris Jul 22 '12 at 4:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.