Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to set up an initial puppet config but struggling to get it working due to failures on my first file inside the file bucket. Everything seems fine at first glance, I'm thinking I need a second opinion just to catch the issue. So I've defined the node in nodes.pp as follows:

# cat /etc/puppet/manifests/nodes.pp
node defaultclass  {
    include baseconfig
}
node 'buildmirror.briggs.uk.to' {
    include ntp
    include packages
}

My filebucket resides here:

# cat /etc/puppet/modules/baseconfig/manifests/ntp.pp
class ntp {
file { "/etc/ntp.conf":
source => "puppet:////modules/baseconfig/ntp.conf",
        owner => root,
        group => root,
        mode => 644,
        require => Package ["ntp"]
}

#file { "/var/log/ntp":
#ensure => directory,
#owner => ntp,
#group => ntp,
#mode => 755,
#}
service { "ntpd":
require => File["/etc/ntp.conf"],
subscribe => File["/etc/ntp.conf"],
ensure => running,
enable => true,
}
}

and the file exists in the correct directory (I think)

# ls -al /etc/puppet/modules/baseconfig/files/ntp.conf
-rwxr-xr-x 1 root root 1862 Jul 20 15:50 /etc/puppet/modules/baseconfig/files/ntp.conf

The problem I have is that when I run puppetd --test I get the following errors:

# puppetd --test
info: Retrieving plugin
info: Caching catalog for hostname
info: Applying configuration version '1342971406'
err: /Stage[main]/Ntp/File[/etc/ntp.conf]: Could not evaluate:     Could not retrieve     information from   environment production source(s) puppet:////modules/baseconfig/ntp.conf  at         /etc/puppet/modules/baseconfig/manifests/ntp.pp:8
 notice: /Stage[main]/Ntp/Service[ntpd]: Dependency File[/etc/ntp.conf] has failures: true
 warning: /Stage[main]/Ntp/Service[ntpd]: Skipping because of failed dependencies
 notice: Finished catalog run in 0.34 seconds

What could be causing this? I've verified the permissions on the file in the filebucket (and even tried setting them to 777 to ensure it's not a perms issue) Any help appreciated!

share|improve this question

1 Answer 1

Too many slashes - try puppet:///modules/baseconfig/ntp.conf instead of puppet:////modules/baseconfig/ntp.conf.

A quick note on terminology - the filebucket is actually the mechanism that clients use to archive the old version of a file that's being replaced. What you're using here is the simply called the "file server".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.