Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When sending out emails with postfix I sometimes get this error:

451 #4.1.8 Domain of sender address <user@mydomain.tld> does not resolve 
(in reply to MAIL FROM command)

The domain mydomain.tld is resolvable though, meaning A, MX, PTR records are set properly.

However, the sending server does have a different domain anotherdomain.tld but it is allowed to send emails from mydomain.tld since I set the MX records of mydomain.tld to anotherdomain.tld. The envelope from of the problematic emails is user@mydomain.tld.

Is there some other dns entry I have to set?

Or how else could I solve the problem? (I would like to keep the server structure though)

share|improve this question
    
As womble says, it's very hard for us to offer any real information while you redact the domain in question. DNS is a public resource; I urge you, and authors of similar questions, not to redact domains in such questions. –  MadHatter Jul 23 '12 at 12:02
    
@MadHatter: You are right. However I may not publish the domain name here unfortunately... –  horen Jul 23 '12 at 12:16
    
Whoever says that is foolish. You'll have this problem until you fix it, and being open about the domain name is likely to get the problem fixed more quickly. So ask whoever says that whether they prefer to be a little embarrassed but have working email, or save face but have non-working email. Though I'm not even sure why they'd be embarrassed; we all have stuff break all the time, you're not the only ones! –  MadHatter Jul 23 '12 at 12:23
add comment

1 Answer

up vote 2 down vote accepted

The problem is simply one of DNS resolution. Either the receiving MTA doesn't have reliable DNS resolution, or your DNS servers are flaky. Without knowing what domain mydomain.tld actually is, it's impossible for anyone to determine whether the latter is the case, but the more recipient domains who are sending you this error, the less likely the former becomes.

share|improve this answer
    
so you think the problem isn't that anotherdomain.tld is sending with the envelope from user@mydomain.tld but that anotherdomain.tld does actually not resolve? which dns entry does that error msg actually mean - is it the A RECORD? If it would be the A record of mydomain.tld, it would obviously not point to the IP of anotherdomain.tld - maybe that's the problem? –  horen Jul 23 '12 at 11:28
    
In short: No. ANY. No. –  womble Jul 23 '12 at 11:39
    
@adaptr: What does Postfix's resolver have to do with this problem? It's an error from the recipient MTA. –  womble Jul 23 '12 at 12:42
    
I re-read it and deleted it, sorry. –  adaptr Jul 24 '12 at 9:42
    
I was able to fix it by changing the DNS entries for the MX record. I debugged using the dig command. It returned ;; Truncated, retrying in TCP mode instead of a valid answer. Now everything is fine –  horen Jul 27 '12 at 8:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.