Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to set up a copy of the CodeCollaborator trail software for performing code reviews but when I try and point it to our SVN repository I get the error

Error: Invalid input: Version control server configuration error: Could not create valid Subversion configuration based on configured repository url: svn: OPTIONS of 'https://svnserver:8443/svn/Repository': Server certificate verification failed: issuer is not trusted (https://svnserver:8443)

However, I've no idea which certificate to grab or where to install it. I've tried running a simple svn list https://svnserver:8443/svn/Repository/ which gives me the error

Error validating server certificate for 'https://svnserver:8443/svn/Repository/:

  • The certificate is not issued by a trusted authority. Use the fingerprint to validate the certificate manually!

Certificate information:

  • Hostname: svnserver.domain.local
  • Valid: from Tue, 12 Aug 2008 10:27:29 GMT until Fri, 10 Aug 2018 10:27:29 GMT
  • Issuer: svnserver.marvel.local
  • Fingerprint: (set of hex values) (R)eject, accept (t)emporarily or accept (p)ermanently?

Thereafter I can run svn commands at the commandline without a problem, but still get the error setting up CodeCollaborator.

What certificates do I need to install, and where, to get this up and running?

share|improve this question

1 Answer 1

CodeCollaborator claims to use your svn client config, so I think that you need to get your svn client configured to trust the issuer ... that is, the certificate you need is for the CA (in your example, this is svnserver.marvel.local). Store it somewhere locally and point to it in your servers file as described in the online svn book.

I also noted that the CodeCollaborator people are supposedly willing to help trial users get things working, so you could try that too.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.