Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My client's Exchange 2010 has been set to send/receive messages up to 25MB, however Exchange still rejects messages 16-20MB in size:

Technical details of permanent failure:
Google tried to deliver your message, but it was rejected by the recipient domain. 
We recommend contacting the other email provider for further information about the 
cause of this error. The error that the other server returned was: 552 552 5.3.4 
Message size exceeds fixed maximum message size (state 17).

They don't want a 25MB limit, only 20MB. But the limit doesn't seem to have an effect - messages still get rejected due to size.

Send & Receive connectors are all set to 25MB limit.

Anyone have any ideas on this?

share|improve this question
    
Is the 16-20 MB in raw or actually format before it gets encoded? Or after uuencoding (it grows by about a third by that. A mail with a single 16MB attachment would grow to about 24MB while being in transit). –  Hennes Jul 24 '12 at 0:54
    
I created my test attachments using DOS command: fsutil file createnew c:\test 19000000 –  Ash Jul 24 '12 at 3:09
    
fsutil file createnew c:\test 19000000 should have create a file with 19000000 bytes. (Or written differently 18554.6KB or 18.12MB). After during transit that should have increased the size to about 24.16MB. That is less than the 25MB limit.So I guess you are just in the safe zone and the problem lies elsewhere. ( For future reference: Mail does not support binary data, hence this as these are used: en.wikipedia.org/wiki/Uuencoding ) –  Hennes Jul 24 '12 at 12:57
    
Thanks for your assistance. The message size limit is fine in my opinion now. –  Ash Jul 24 '12 at 23:35

1 Answer 1

up vote 3 down vote accepted

In addition to your limits on send & receive connectors, there's a global setting that controls message size limit, as well as possibly limits on message size for individual mailboxes.

The global limit is found by going to: EMC -> Organization Configuration ->Hub Transport -> Global Settings -> Transport Settings

And be aware that this setting can take some time to apply.

And, here's a link to an article on the subject, which actually has three more locations that probably don't apply, but that you can also find message limits in.

share|improve this answer
1  
I checked this setting, increased it from 20MB to 25MB. 19MB attachment test email was still rejected. Transports Settings and Send & Receive Connectors are all set to 25MB. No user has a message limit of their mailbox. –  Ash Jul 24 '12 at 3:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.