Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

It seems that my VPS doesn't have SSH installed(I'm not sure yet), because I get no response from the server, and I cant ping it. So I think this is weird, because I cant control my VPS by anyway.

When I try to connect i get connection timeout, and no route to host.
I'm running Ubuntu 12.04LTS.
The way I'm trying to connect is ssh user@ipv4address. Hope this helps.

So , I wanted to know:

  1. How to make sure I don't have SSH installed on my server?
  2. How to install that, is this something should come with the OS template itself?

I tried searching for answers, but I was out of luck.

share|improve this question
Please, for the person who's downvoting - may I know the reason of the downvote? Since I did my homework, I searched alot, tried, and even changed OS before asking here. – Rev3rse Jul 24 '12 at 12:22
up vote 3 down vote accepted

Most VPS providers offer a way to get a remote console on your linux instance. For instance, if you use Rimuhosting, you would follow these procedures.

Short answer: Get a remote console on the server and do what you need to do to fix it.

share|improve this answer
Well, what if the VPS provider doesn't have a remote console? – Rev3rse Jul 24 '12 at 12:06
Then you need to get help from your VPS provider to fix whatever is wrong. Honestly, we can't help at this point if there is no console or network connectivity – Mike Pennington Jul 24 '12 at 12:15
@AzizAG Get a new VPS provider. – EEAA Jul 24 '12 at 13:04

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.