Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For some reason, smbd never seems to start correctly when the server starts. Simply calling /etc/init.d/smbd restart works great, but is there a way that I can either fix the underlying issue or add /etc/init.d/smbd restart to a cron? I just can't seem to figure out how to add the restart parameter.

Jul 24 08:56:33 server smbd[1029]: [2012/07/24 08:56:33.898006,  0] smbd/server.c:1107(main)
Jul 24 08:56:33 server smbd[1029]:   standard input is not a socket, assuming -D option
Jul 24 08:56:34 server smbd[1277]: [2012/07/24 08:56:34.099875,  0] printing/print_cups.c:110(cups_connect)
Jul 24 08:56:34 server smbd[1277]:   Unable to connect to CUPS server localhost:631 - Connection refused
Jul 24 08:56:34 server smbd[1029]: [2012/07/24 08:56:34.099980,  0] printing/print_cups.c:487(cups_async_callback)
Jul 24 08:56:34 server smbd[1029]:   failed to retrieve printer list: NT_STATUS_UNSUCCESSFUL
share|improve this question
On what OS do you work? When do the log messages you posted appear? – Sven Jul 24 '12 at 13:28

Check to make sure smbd is starting after cups.

share|improve this answer
How can I check/alter that? – bswinnerton Jul 24 '12 at 13:39
Under Linux (assuming sysv-style init, not systemd) the number prefixing the init script in /etc/rc[0-S].d/ indicates the order it starts in. – Vikki Roemer Jul 26 '12 at 21:07

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.