Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm using Plesk control panel v10 on a Windows dedicated server.

Plesk 11 will also upgrade PHP version to 5.3, but some of the websites on server do not support 5.3.

Is it possible to have both versions (5.2 and 5.3) after the Plesk is updated?

Are there any steps I should take after update?

Thank you

[EDIT]

Found this article: http://kb.parallels.com/en/113179 but it deals only with upgrading the PHP version, not Plesk version as well.

share|improve this question

closed as off-topic by HopelessN00b Jan 14 at 6:33

  • This question does not appear to be about server, networking, or related infrastructure administration within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

    
This question appears to be off-topic because it is about working with a service provider's management interface, such as cPanel. –  HopelessN00b Jan 14 at 6:33

2 Answers 2

up vote 2 down vote accepted

I think it is b). New PHP will have to be installed separately from Plesk upgrade. – Sergey L Aug 29 '12 at 5:56 We had Parallels perform an update to our Plesk Panel recently. Version 9 was updated to v11 and it did not include PHP 5.3 as part of the process. 5.3 can be installed separately though, we have had this done.

share|improve this answer

Plesk for Windows will work well with PHP 5.2 and PHP 5.3 installed simultaneously. Plesk for Linux cannot do that so far.

share|improve this answer
    
Thanks for the reply. The hosting company in the meantime said that upgrading Plesk from 10 to 11 will NOT change PHP version, but will only allow Plesk to be run on PHP 5.3. The plesk update log does not give exact information on this and their forums are useless. I'm skeptical about this though. Do you know if upgrading Plesk to v11 will a) upgrade PHP version OR b) keep the same PHP version and allow Plesk to run on 5.3? –  Ivanhoe123 Aug 15 '12 at 7:48
    
I think it is b). New PHP will have to be installed separately from Plesk upgrade. –  Sergey L Aug 29 '12 at 5:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.