Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a left handed user that is trying to use remote desktop to our windows server 2008 terminal services server. Their local machine works fine, with the mouse settings swapped around. However, when this person connects in to the terminal server, the mouse settings change to the default right handed settings on the terminal server.

How can I change those settings for the user (they are not administrator)?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

The easiest way to fix this is to change the settings on the user. One or two solid whacks to the user's left hand with a hammer (or similar object) is an effective way to get them to use their mouse as a righty.

If that doesn't work for you for some reason, the second easiest way I've found is to give the user access to a limited control panel on the server where they can reverse their mouse settings themselves. (At least as of Windows 2003, this was a per-user setting, so it won't impact everyone who uses the server.)

You can do this via GPO, and will be found under User Configuration -> Administrative templates -> Control Panel -> "Show only specified Control Panel applets" -> mouse.cpl

You can also solve the problem with roaming profiles fairly trivially, but I figure you don't use those, or you'd have fixed it already. Roaming profiles are still more of a pain than they're worth anyway. :(

share|improve this answer

Have them right-click on their desktop (or wherever they can create shortcuts), and create a shortcut to main.cpl (the Mouse control panel).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.