Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have been pulling my hair out all day on this, so I hope someone has an answer!

I have a PC running Windows 7 with XAMPP. I have set up a virtual host within Apache with the relevant entries in the host file. I have also set up the correct entries within the host files of client PCs that are supposed to access the server via web browser (using the virtual host names) over a local network.

I have done this before with no issues. What I am trying to do now is replicate the setup across a different set of machines running on a completely independent closed network that is not connected to the Internet or anything else.

It works, EXCEPT that there is a TREMENDOUS delay when attempting to connect to the server from the client PCs. It takes about 10 seconds to load a web page. This happens whether I try to connect to the virtual host or the server's IP address directly.

When connecting to the virtual hosts or localhost from the server itself, there is no delay. There is only a delay when accessing the Apache server from client PCs.

A ping from the client to server returns a latency of 2ms, so I don't think there is any inherent network communication issues.

What I have tried:

1) Using WAMP instead of XAMPP. 2) Using a different router. 3) Using various client machines to test. 4) Disabled IPv6. 5) Played with tons of permutations of the host file on the server and clients. I am pretty sure it is set up correctly though because it mirrors an existing configuration I am using without issue.

For some reason, accessing the server over HTTP causes a huge delay, EVEN when typing in the IP address directly into the browser.

I really need to get this working very soon - any ideas???

share|improve this question

closed as off-topic by Tom O'Connor Aug 14 '13 at 21:20

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must be relevant to professional system administration. Server Fault is a site dedicated to professionals; novice questions are off-topic. Please see the Help Center for more information on topicality. The best advice we can give you is to hire a professional to help you out." – Tom O'Connor
If this question can be reworded to fit the rules in the help center, please edit the question.

add comment

1 Answer

Aren't you using HostnameLookups in your apache conf ? This would mean apache has to do a reverse DNS lookup of the incoming connection to write an entry in the log file.

I noticed that having a misconfigured reverse DNS can significally slow down the initial setup of a telnet connection, so it might be your problem. See http://www.debian-administration.org/articles/188 for details.

share|improve this answer
    
Thanks for the thought - but due to frustration I did a fresh install of Windows and XAMPP, and voilla - problem gone. I'm frustrated I never figured out what was going on, but I'm happy it's fixed. Good creative thinking though - never saw anything along those lines in my online travels whilst searching for a solution. –  R C Jul 24 '12 at 19:12
    
+1 This is a perfect fit for a DNS issue. –  David Schwartz Jul 24 '12 at 19:22
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.