Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have installed ubunutu witha apache on my pc and everything works great except: I don't know how to enable perl, everything I have tried either gave me a server error or gave me a 403 for the perl scripts.

Please tell me how to enable Perl. Thanks!

share|improve this question
    
Are you talking about mod_perl or CGI scripts? Please add some details, what you tried, exact error message, config etc. –  C. Ramseyer Jul 25 '12 at 0:14
    
Im not sure what CGI is, but I want to be able to run perl scripts on .pl files, I am receiving the following error [24/Jul/2012:20:24:51 -0400] "GET /test.pl HTTP/1.1" 403 410 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_4) AppleWebKit/536.19 (KHTML, like Gecko) Version/6.0 Safari/536.19" and I used: <Directory /var/www/> Options +ExecCGI AddHandler cgi-script .pl </Directory> in my apache.conf file I am not sure whats wrong, please help me out, I have no other details. –  rgbc Jul 25 '12 at 0:26
    
@rgbc: It will be better and more readable to include your last comment in your question. –  Khaled Jul 25 '12 at 7:03

1 Answer 1

does your script have #!/usr/bin/perl as its first line?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.