Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

My Cisco 877 is booting with the following results, and I'm looking to understand why. The below is happening consistently. I'm doing this via console cable to my PC using HyperTerminal.

The first portion of the boot output is as expected. I reach: Self decompressing the image : #...# [OK]. From this point, junk characters are scattered throughout the boot output. I then reach Press RETURN to get started!

Here it gets stuck, slowly printing more garbage.

I assume this means the IOS image file is corrupt, considering the problems only occur immediately after decompressing the image. Is this accurate?

Is there a chance there is a hardware issue at fault here?

Would you expect this problem to be resolved by replacing the IOS image?

Most online resources I found on corrupt IOS images were in regard to being forced into ROMMON mode, or instructions on how to replace the image. I'm more interested in understanding the cause of the problem.

share|improve this question

migrated from superuser.com Jul 25 '12 at 1:24

This question came from our site for computer enthusiasts and power users.

    
Just curious - is this in an office environment? If its at a professional level, serverfault may be a better place to ask. Flag it for migration in that case, and the mods should take care of it. –  Journeyman Geek Jul 20 '12 at 7:29
1  
It could be a hardware issue, the cable you are using, or even the HyperTerminal settings. Telnet into the unit, does it look okay that way? It's probably not the IOS image -- if you are getting as much as you are and you haven't tried to upgrade anything recently. –  Brock Adams Jul 20 '12 at 11:17
    
@JourneymanGeek, thanks for the tip. I wondered where it fit best, and put it here since I ask as a hobbyist. Will consider further though. –  Robyn Jul 22 '12 at 23:41
    
@BrockAdams, I'll try toggling what you suggest and see how I go there. Thanks for the hints. –  Robyn Jul 22 '12 at 23:42

1 Answer 1

This looks like a serial speed issue. The first words you see are from the bootloader, which look fine, and then the IOS is set to another speed, hence the garbage.

Try to set up the terminal speed differently, like 9600/8N1, 38400/8N1,...

This will change the behavior as the output from the bootloader will be crippled, but once IOS is started, it should look nicer :)

share|improve this answer
    
Thanks for the suggestion. I tried all other possible speeds with the previous settings to no avail. Then trying different configuration register values, the following is the best I now get. Setting confreg 0x2102 and connecting at 9600 I get clean output to the point of: 128K bytes of non-volatile configuration memory. 36864K bytes of processor board System flash (Intel Strataflash) €€€€€€€€€€€€€€€€€€€€€€€€€€€€€€€€€€€€€€€€€€€€€€€€€€€€€ Will tinker further! Suggestions as to what's going on always welcome. –  Robyn Jul 30 '12 at 7:24
    
@Robyn: Could you take a screenshot of the boot output on your terminal emulator ? –  petrus Jul 30 '12 at 10:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.