Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I added a this .repo file in /etc/yum.repos.d/ on CentOS 6. Then when I try to install package from this repo I do not see the mirrors loaded from this repo.

Output of yum repolist is

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: ftp.iitm.ac.in
 * epel: mirror01.idc.hinet.net
 * extras: ftp.iitm.ac.in
 * updates: ftp.iitm.ac.in
repo id              repo name                                            status
base                 CentOS-6 - Base                                      6,346
epel                 Extra Packages for Enterprise Linux 6 - x86_64       7,595
epel-spectrum2       Spectrum is an XMPP transport/gateway/server.           14
extras               CentOS-6 - Extras                                        4
updates              CentOS-6 - Updates                                     250
repolist: 14,209

So it seems like repo file is configured properly, but when I try to install a package from it, the output is

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: ftp.iitm.ac.in
 * epel: mirror01.idc.hinet.net
 * extras: ftp.iitm.ac.in
 * updates: ftp.iitm.ac.in
Setting up Install Process
No package spectrum2 available.
Error: Nothing to do

I'm sure the package is available in that repo, cause their website states it. What to do to have packages from this repo? Am I missing any settings?

share|improve this question
    
what does "yum search spectrum" say? –  w00t Jul 25 '12 at 10:41
    
@w00t it says No package spectrum2 available. –  Harry Joy Jul 25 '12 at 10:43
    
@Harry Now it should work. I've just installed and checked - all working fine. –  Denis Jul 26 '12 at 23:35
    
Yes, now I can see the rpm and can install it. Are you in the development team of Spectrum 2? –  Harry Joy Jul 27 '12 at 4:03
    
No, I'm not. It's only a coincidence. I experienced the same problem with package install, and seems they have recently fixed it. –  Denis Jul 27 '12 at 4:21

2 Answers 2

I agree their documentation says those repos make the spectrum2 packages available, but they're not there. When I look in http://repos.fedorapeople.org/repos/jkaluza/spectrum2/epel-6/i386/ and http://repos.fedorapeople.org/repos/jkaluza/spectrum2/epel-6/x86_64 , there are no spectrum packages there. yum is behaving correctly, and you will need to speak to the repository maintainers to find out what's wrong.

Edit: I note that the packages have since appeared in the repositories, so you should now be OK. Yes?

share|improve this answer
    
yes.. there is no package named spectrum in it. –  Harry Joy Jul 25 '12 at 10:52
    
That's the point. The repo maintainer has not actually placed the packages in the repository. –  Michael Hampton Jul 25 '12 at 12:18

Try yum clean all to clean all cached files.

You can also try yum install package --enablerepo=epel-spectrum2

share|improve this answer
    
Nothing worked :( –  Harry Joy Jul 25 '12 at 10:32
    
@HarryJoy Packages are available here repos.fedorapeople.org/repos/jkaluza/spectrum2/epel-6/SRPMS .. try yum install package --enablerepo=epel-spectrum2-source –  Linux Intel Jul 25 '12 at 10:40
    
That's an SRPM, ie a source package. I agree that, failing all else, the OP could build from that SRPM to get a working binary RPM for local installation, but it's not a trivial process. –  MadHatter Jul 25 '12 at 10:54
    
@MadHatter yeah its source, and it requires too much dependencies so it becomes hard to install it from source. :( –  Harry Joy Jul 25 '12 at 11:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.