Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm attepting to install the adblock chrome extension using Google's Chrome ADM's.

User Configuration/Policies/Classic Administrative Templates/Google/Google Chrome/Extensions

Configure the list of force-installed extensions

On the list I have the extension's ID and update URL, which google alludes to in their documentation here and here:


I managed to get the update URL using the instructions in this question, but so far, I have been unsuccessful in that the extension is not actually getting installed.

Is there something I'm missing or doing incorrectly?

share|improve this question
run rsop.msc in a client computer to check if the gpo is correctly applying – Ricardo Polo Aug 5 '12 at 22:08
According to RSOP, yes, the GPO is being applied. – Force Flow Aug 6 '12 at 21:18
What are the OS versions of the client? – SpacemanSpiff Aug 7 '12 at 22:27
Windows XP and Windows 7; both running the latest service packs and updates. XP has the client side extensions update installed. – Force Flow Aug 8 '12 at 13:15
up vote 3 down vote accepted

Apparently, the "Configure the list of force-installed extensions" ADM policy simply does not work at all.

So, I ended up having to use the registry method.

NOTE: If using the registry method, the extension is automatically disabled in version 25 of Chrome. Also note that for Chrome 25 and up, the ADM policy now works.

  1. Find the extension ID of your desired extension. This is the unique ID of the extension in the Chrome webstore. You can see this ID in the URL of the extension ie:

or, Open the extensions list in Chrome; tick the Developer Mode tick box and then click the arrow next to the extension you want to deploy - the extension ID will be underneath the extension's heading.

At this point, it is worth making note of the extension's version number too, as you will need this later on in the deployment.

  1. Open a browser other than chrome - Firefox will work fine. Paste the following line into the address bar, replacing the ----- with the extension ID Press enter to access this URL; you will be prompted to save the .crx file.

Copy this .crx file to your deployment shared folder eg \Server\SoftwareDeployment\ChromeExtensions\.crx


Next, add the registry keys in computer configuration\preferences\windows settings\registry:

Create the following registry key values:

HKEY_LOCAL_MACHINE\SOFTWARE\Google\Chrome\Extensions\[id of your extension crx]\path
VALUE: "\\server\NETLOGON\path\to\your\extension.crx"
HKEY_LOCAL_MACHINE\SOFTWARE\Google\Chrome\Extensions\[id of your extension crx]\version
VALUE: [version of your .crx as specified in the manifest]


share|improve this answer

The problem with the original configuration is that the URL after the extension ID must point to the update URL, not to the CRX URL. The correct URL for the webstore is

This is described at Please file a bug on the chromium bug tracker using the Enterprise Issue template if a policy isn't working as expected.

share|improve this answer

Since I have no rep I can't upvote or comment, but I had the same misunderstanding as the OP and Joao da Silva's answer helped me so I wanted to contribute in some way.

He is correct about the URL.

I did the policy simply by saying gighmmpiobklfepjocnamgkkbiglidom;

One gpupdate /force later and the extension was installed.

Here is a screenshot: (its a link since i can't post images until I have 10 rep) =(

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.