Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Problem:

When opening windows "QUEUE MESSAGES" on windows server 2003 I received the error message

"The list of messages cannot be retrieved. Error: Access is denied"

Why?

Recreated following these steps:

  • Windows Server 2003 standard 64-bit
  • Right click MY COMPUTER
  • Select MANAGE
  • SERVICES
  • MESSAGE QUEUING
  • PRIVATE QUEUE
  • MYSERVICE
  • QUEUE MESSAGES

Error message displayed:

"The list of messages cannot be retrieved. Error: Access is denied."

Setup/configuration currently deployed:

  • Logged in as local administrator.
  • Machine is stand alone.
  • WCF service is running (using WCF specific user)
  • WCF user account is a member of the local ADMIN group.
  • dot net 4.0.
  • Messing Queueing service is running (local system)
  • Maybe a permissions issue creating the error.
share|improve this question

1 Answer 1

up vote 1 down vote accepted

This can happen if the .NET Service removed the "Everyone" group from the permissions the private queue. Here are some steps you can take to resolve this:

  1. Stop the MSMQ Service
  2. Open the folder C:\WINDOWS\system32\msmq\storage\lqs
  3. Find the file in this folder that describes your queue -- (incommingQueue)
  4. Using notepad, open the lqs file for some other private queue that has good security permissions. (If you don't have any other private queues create one)
  5. Locate the line in the file that begins Security=....
  6. Copy the whole line to your clipboard (watch out for Word Wrap, this line will be quite long)
  7. Open the lqs file for your problem queue in your text editor
  8. Overwrite the Security=... line in this file with the contents of your clipboard
  9. Save the modified lqs file
  10. Start the MSMQ service

You should find that the problem queue now has the same permissions as the queue whose security settings you copied at step 6 above.

share|improve this answer
    
It works, thank you. –  Dariusz Wozniak Oct 8 '12 at 11:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.