Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently set up automysqlbackup on a Ubuntu server.

The script runs fine and doesn't report any errors-- it creates the tar.gz file as expected. However, when I extract the actual sql file from the archive, it is a zero-length file.

Is there anything obvious that I'm missing in the configs?

Here's the only parts of the config file I modified:

# Username to access the MySQL server e.g. dbuser
USERNAME=myusername

# Username to access the MySQL server e.g. password
PASSWORD=mypass

# Host name (or IP address) of MySQL server e.g localhost
DBHOST=mysql.remotehost.com

# List of DBNAMES for Daily/Weekly Backup e.g. "DB1 DB2 DB3"
# Note that it's absolutely normal that the db named "mysql" is not in this
# list, as it's added later by the script. See the MDBNAMES directives below
# in this file (advanced options).
# This is ONLY a convenient default, if you don't like it, don't complain
# and write your own.
# The following is a quick hack that will find the names of the databases by
# reading the mysql folder content. Feel free to replace by something else.
# This one does a list of dbs using a MySQL statement.
DBNAMES='mydbname'

# Backup directory location e.g /backups
# Folders inside this one will be created (daily, weekly, etc.), and the
# subfolders will be database names. Note that backups will be owned by
# root, with Unix rights 0600.
BACKUPDIR='/home/myuser/automysqlbackup'
share|improve this question

1 Answer 1

up vote 1 down vote accepted

D'oh. User error. My host was not accepting connections from my IP, but for some reason was not returning any error, so the script just hung.

Odd that automysqlbackup didn't report any issue after apparently timing out, but it's resolved now.

share|improve this answer
    
Thanks for sharing what went wrong. Please select your answer as the right answer so others know that you figured it out. –  Pothi Jul 28 '12 at 1:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.