Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install ulogd tool in my system. ulogd requires nfnetlink_conntrack subsystem in the kernel. It seems nfnetlink_conntrack is not available in the Linux version(RHEL5) that I'm using. How to get that in my system? I can not find any info on this in Google, other than I get a bunch of results that give a link to the source code.

share|improve this question
Actually I found the solution. ulogd works with old kernels also. Only problem is my system was not supporting AF_UNSPEC address family. ulogd tried to use that, and it was failing. I changed the address family from AF_UNSPEC to AF_INET, and it worked!. – Goms Aug 3 '12 at 0:26

Recompile your kernel to enable it:

--- Networking support          
      Networking options  --->  
          [*] Network packet filtering framework (Netfilter)  --->
              Core Netfilter Configuration  --->
                  <*>   Connection tracking netlink interface
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.