Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

OS: Debian Squeeze x64 running on XenServer

Have been googling the error with no luck (or I just fail at googling); any help on resolving this? Any would be greatly appreciated! -Also posted on WebHostingTalk with no luck yet (http://www.webhostingtalk.com/showthread.php?t=1177066)

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created or
been moved out of Incoming. The following information may help to
resolve the situation:

The following packages have unmet dependencies: libreadline6-dev :
Depends: libreadline6 (= 6.1-3) but 6.2-8 is to be installed E: Unable
to correct problems, you have held broken packages.


Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created or
been moved out of Incoming. The following information may help to
resolve the situation:

The following packages have unmet dependencies: libreadline5-dev :
Depends: libreadline5 (= 5.2-7) but 5.2-11 is to be installed E:
Unable to correct problems, you have held broken packages.


# apt-get install libreadline5 Reading package lists... Done Building dependency tree Reading state information... Done libreadline5 is
already the newest version. The following packages were automatically
installed and are no longer required: dbconfig-common g++-4.4
libace-5.7.7 libgs8 libjpeg62 libjs-mootools liblcms1 liblqr-1-0
libmagickcore3 libmagickwand3 libmysqlclient16 librpmio1 libserf-0-0
libsqlite0 libstdc++6-4.4-dev libt1-5 Use 'apt-get autoremove' to
remove them. 0 upgraded, 0 newly installed, 0 to remove and 0 not
upgraded.


# apt-get install libreadline6 Reading package lists... Done Building dependency tree Reading state information... Done libreadline6 is
already the newest version. The following packages were automatically
installed and are no longer required: dbconfig-common g++-4.4
libace-5.7.7 libgs8 libjpeg62 libjs-mootools liblcms1 liblqr-1-0
libmagickcore3 libmagickwand3 libmysqlclient16 librpmio1 libserf-0-0
libsqlite0 libstdc++6-4.4-dev libt1-5 Use 'apt-get autoremove' to
remove them. 0 upgraded, 0 newly installed, 0 to remove and 0 not
upgraded.

Also tried: Try sudo apt-get install lib32readline5-dev Same error with: sudo apt-get install -f lib32readline5-dev

#apt-get install lib32readline5-dev Reading package lists... Done Building dependency tree Reading state information... Done Some
packages could not be installed. This may mean that you have requested
an impossible situation or if you are using the unstable distribution
that some required packages have not yet been created or been moved
out of Incoming. The following information may help to resolve the
situation:

The following packages have unmet dependencies: lib32readline5-dev :
Depends: lib32ncurses5-dev but it is not going to be insta lled
Depends: libc6-dev-i386 but it is not going to be installe d E: Unable
to correct problems, you have held broken packages.
# apt-get install lib32ncurses5-dev Reading package lists... Done Building dependency tree Reading state information... Done Some
packages could not be installed. This may mean that you have requested
an impossible situation or if you are using the unstable distribution
that some required packages have not yet been created or been moved
out of Incoming. The following information may help to resolve the
situation:

The following packages have unmet dependencies: lib32ncurses5-dev :
Depends: lib32ncurses5 (= 5.7+20100313-5) but 5.9-10 is to be
installed Depends: lib32c-dev E: Unable to correct problems, you have
held broken packages.
# apt-get install libc6-dev-i386 Reading package lists... Done Building dependency tree Reading state information... Done Some
packages could not be installed. This may mean that you have requested
an impossible situation or if you are using the unstable distribution
that some required packages have not yet been created or been moved
out of Incoming. The following information may help to resolve the
situation:

The following packages have unmet dependencies: libc6-dev-i386 :
Depends: libc6-i386 (= 2.11.3-3) but 2.13-33 is to be installed
Depends: libc6-dev (= 2.11.3-3) but 2.13-33 is to be installed
Recommends: gcc-multilib but it is not going to be installed E: Unable
to correct problems, you have held broken packages.
share|improve this question
    
Have you run apt-get update recently? And what apt sources do you have configured? Depends: libreadline6 (= 6.1-3) but 6.2-8 is to be installed tells me that you've installed that from the testing or unstable repositories, instead of the stable repository that libreadline6-dev is trying to install from. –  Shane Madden Jul 27 '12 at 5:17
    
pastebin.com/fjNdejAD I also believe you are correct that we installed from test/unstable repos. I removed the unstable repos (dotdeb) a few days ago, but this was installed previously to that by a friend. Anyway to fix this issue? –  Maki Jul 27 '12 at 5:37
    
You'll need to downgrade the dependency package to stable. Probably easiest to remove and re-install it. –  Shane Madden Jul 27 '12 at 5:43
    
Removed both libreadline5 and 6; accidently removed apt-get with it! I'm assuming I will need to use a deb/rpm to get it back? Any chance you could help me with that would be appreciated! (-bash: /usr/bin/apt-get: No such file or directory ). If not, will it be easier to just reinstall the VM? (using XenServer) –  Maki Jul 27 '12 at 5:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.