Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have installed Nagios by following this tutorial here.

But when I tried to connect to localhost/nagios3 using curl from console, making sure that Nagios is installed and running(since I'm getting an output stating that authorization required).

But when I tried to connect to :


I'm getting page not found error!

What went wrong?

share|improve this question
why a downvote? –  batman Jul 27 '12 at 10:09

1 Answer 1

up vote 1 down vote accepted

If you are connecting to


Than add a little s:


Is it a spelling mistake?


curl --user name:password http://i-cXXXXX.compute.amazonaws.com/nagios3/ --location

To authenticate with curl if you want to check if it is giving the correct output

share|improve this answer
No its not a spelling mistake. curl utility is working with provided user name and password. –  batman Jul 27 '12 at 10:10
I dont get it... you are saying that localhost/nagios3 is working but http://i-cXXXXX.compute.amazonaws.com/nagio3/ is not working and giving you 404. Well if there is no virtual host with alias for nagio3 you will receive just that. Are you saing that you have two virtual hosts? One for nagios3 and one with nagio3 ? What for? –  mnmnc Jul 27 '12 at 10:13
Sorry that was being my spelling mistake. ` localhost/nagios3` this works. And I have only one virtual host. so http://i-cxxxxx.compute.amazonaws.com/nagios3/ is not working. Thats my problem. –  batman Jul 27 '12 at 10:16
1. check if amazonaws.com is working 2. check if compute.amazonaws.com is working 3. check if i-cxxxxx.compute.amazonaws.com is working 4. check if http://i-cxxxxx.compute.amazonaws.com or https://i-cxxxxx.compute.amazonaws.com is working –  mnmnc Jul 27 '12 at 10:19
I guess the problem might be because, I'm running my instance inside a VPC. I guess this is causing problems for me. Are there any way to disable my instance from vpc and then add it back? –  batman Jul 27 '12 at 10:36

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.