Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I cannot connect clients to sbs2003 domain because of this error: The format of specified network name is invalid.

Before that there is a prompt for a login and password, so the server is found. I can't also view the server resources via \ \ servername or \ \ ServerIP because it can not find the path. I can not add the computer account by servername/ConnectComputer because after entering the login and password I can wait forever.

Clients can browse the web without any problems with the DNS server address - sbs2003.

nslookup servername gets the correct server name and the correct IP address. Pings to the server works without a problem.

Gateway / router / firewall for the network is debian, also DHCP Server. The topology is as follows:

modem - debian - lan where there are clients and the server SBS2003

Client gets the following configuration from DHCP server:

Connection-specific DNS Suffix: domain_name
IP Address: 192.168.20.100
Subnet Mask: 255.255.255.0
Default Gateway: 192.168.20.1 - network interface on Debian
DHCP Server: 192.168.20.1
DNS Servers: 192.168.20.2 - SBS2003 server address
Primary WINS Server: 192.168.20.2

For the SBS:

dhcp service uninstalled

One interface

Interface configuration:

IP Address: 192.168.20.2
Subnet Mask: 255.255.255.0
Default Gateway: 192.168.20.1
DNS server: 192.168.20.2
WINS Server: 192.168.20.2

DNS configuration:

forward here where I have entered OpenDNS DNS addresses

is set to listen on all IP addresses

So once again the internet works without a problem, client gets addressing from a DHCP server, on the client does not work server shares or connecting to a domain. Somebody help me because I no longer have the strength to go further.

share|improve this question
    
You state: "I cannot connect clients to sbs2003 domain... Before that there is a prompt for a login and password, so the server is found." If the client is not connected to the domain, the prompt for a login and password would be for local accounts, not domain accounts, so I'm not sure why you see this as proof the "server is found". –  HighTechGeek Jun 20 at 17:37

2 Answers 2

Host names are not allowed underscores... Or is the underscore just for demonstration purposes? If not I am not entirely sure how you managed to set up your SBS domain with an underscore but be prepared to bin your SBS build and do it with a standard domain name. Also try choosing a meaningful domain name.

share|improve this answer
    
This is just for demonstration purposes. –  skurg Jul 27 '12 at 11:46
    
What is the domain name you're trying to enter? As it's the cause of the error you'll have to include it in your question to get an answer. –  Alex Berry Jul 27 '12 at 11:48
    
and is the dns suffix domain_name or domain_name.tld? It should be the latter. –  Alex Berry Jul 27 '12 at 11:52

Two solutions I found that you might try:

  • It may likely be that SID of the computer is already on the domain.
  • To solved this problem, first rename the computer that's giving the error message.
  • Restart the Computer and than add it back on the domain

The other:

  • When I put in the full dns name "headquarters.rsa.local" I got this message. Once I just put in "headquarters" as the domain, it worked fine and let me join the domain.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.