Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How can I access data from Ext3 partition on external (USB) HDD from Windows Vista box? Or even better from Linux running inside VirtualBox on Vista host.

I'm interested in read, won't need to write, so any read only solution is valid for me (also meaning, that any solution valid for Ext2 is valid).

I've tried Ext2 IFS, but only thing it's gets done is to make disk actually appear in the explorer, but when I try to access it, it tells me, that the disk is not formated. Any suggestions?


locked by HopelessN00b Dec 5 '14 at 6:35

This question exists because it has historical significance, but it is not considered a good, on-topic question for this site, so please do not use it as evidence that you can ask similar questions here. This question and its answers are frozen and cannot be changed. More info: help center.

closed as off topic by Chris S Jan 27 '12 at 4:41

Questions on Server Fault are expected to relate to server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

up vote 1 down vote accepted

I used explore2fs with Windows XP once in the past and it worked. I'm not sure about Vista support. Maybe give it a try?

There is also Linux Reader. Never tried it myself.

Did you use it on external or internal HDD? I'll give it a try. – vartec May 4 '09 at 16:38
It was an external HDD IIRC. – user1799 May 4 '09 at 17:33
I've tried it. No wonder it didn't work. Results, that the partition was ReiserFS, not Ext3. At least Explore2FS gives that information. – vartec May 20 '09 at 15:44

I had this exact same problem with Ext2 IFS on XP, maybe it's the same thing on Vista...

From I downloaded the moundiag.exe and ran it against the drive (G:) that was showing up in explorer. This gave me an informative error (sorry I don't have the exact text) that indicates that it won't work with inode size = 256 which is what my Linux system created them with by default.

So... I hooked the drive back up to my Linux system, made sure I had a good backup, and then used fdisk to delete the existing partition [AND ALL EXISTING DATA] and create a new one -- then did a:

$ sudo mke2fs -t ext3 -I 128 /dev/sdg1

Once that was done, I restored the data, unmounted it from my Linux system, and was able to connect to it with my XP machine (and Mac OS X, too -- using Ext2FSX).

Also noteworthy is that Ext2IFS can ONLY use the first partition... quoting from the troubleshooting guide (link above):

So there is one straight advice only: do not use removable media with more than one partition with Windows.


It's a bug: try mounting and dismounting it from a linux box. The explanation can be found in the IFS page somewhere.


From my experience, none of Windows ext2/3 drivers work properly under Windows Vista and 7RC for large partitions (> about 500Gb). Somewhere in the net there's even an explanation (something like an API change is to blame). I'll post it here if I find it again.


Not the answer you're looking for? Browse other questions tagged or ask your own question.