Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm getting this error message after install ClamAV from direcadmin message system. OS: CentOs 5.

The service 'clamd' on server star.tunahost.net is currently down This message has been automatically generated notifying you that the service clamd is currently down.

Why can I get this error for each hour? I checked up cron jobs and I couldn't find any job about it.

How to control Clamd service?

OS: CentOS with DirectAdmin

share|improve this question
    
I gave this command: # service clamd start I got this error: Starting clamd: LibClamAV Error: cli_loaddb(): No supported database files found in /usr/share/clamav ERROR: Can't open file or directory –  RedLEON Jul 27 '12 at 19:40
    
When you run freshclam and then try to start the clamd service, what happens? freshclam should update/download the latest antivirus DB files. –  cjc Jul 27 '12 at 20:59
    
freshclam -v It doesn't give any error. Current working dir is /var/lib/clamav Max retries == 3 ClamAV update process started at Sat Jul 28 00:29:17 2012 Using IPv6 aware code Querying current.cvd.clamav.net TTL: 94 Software version from DNS: 0.97.5 main.cvd version from DNS: 54 main.cvd is up to date (version: 54, sigs: 1044387, f-level: 60, builder: sven) daily.cvd version from DNS: 15185 daily.cld is up to date (version: 15185, sigs: 239672, f-level: 63, builder: guitar) bytecode.cvd version from DNS: 188 bytecode.cvd is up to date (version: 188, sigs: 38, f-level: 63, builder: neo) –  RedLEON Jul 27 '12 at 21:30
    
Ah, freshclam is putting the files into /var/lib/clamav. Check your clamd.conf for what the database directory is set to (presumably /usr/share/clamav), and point it at the location used by freshclam. –  cjc Jul 27 '12 at 21:32
    
Why freshclam is searching the database in "/var/lib/clamav" directory. How can I change this option? I mean, freschclam update db files to "/var/lib/clamv" but clamd service looking for that files in "usr/share/clamav". –  RedLEON Jul 27 '12 at 21:49

2 Answers 2

up vote 2 down vote accepted

There was a mismatch between the antivirus database directories used by freshclam and clamd. The /etc/freshclam.conf settingDatabaseDirectory was apparently pointing to /var/lib/clamav (which is default for the package), but the corresponding setting in /etc/clamd.conf was pointing to /usr/share/clamav. This mismatch may have been because the OP had compiled clamav on his own.

Once the DatabaseDirectory settings were reconciled between the configuration files, clamd could see the antivirus database and start up successfully.

share|improve this answer

I found my /etc/freshclam.conf had the DatabaseDirectory set to /var/lib/clamav where-as everything was looking at /var/clamav - that fix worked beautifully.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.