Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an IIS 7.5 server which is configured to support MDM checkin over HTTPS using a cert generated from a test CA. The CA cert is installed as a trusted CA on the iOS 5 device. In IIS Manager, I've gone into My Site->Handler Mappings and for every handler associated with *.ashx, under Request Restrictions->Verbs, I have set the radio button to "All verbs" to enable PUT support for the check-in page.

This configuration allowed me to check in yesterday but today, I'm getting 405. I've rebooted the machine since then and after that, I had to make sure the Handler Mappings were set up again.

How do I get IIS 7.5 to allow PUT requests to *.ashx URLs in a permanent way so my MDM server never tells the iOS device 405?

share|improve this question
    
had the handler mappings changed, and did it work post-reboot-and-remap? –  TristanK Jul 28 '12 at 7:28
    
And to address the "in a permanent way" - any configuration should be permanent. It's all file-based stuff. Either applicationhost.config or web.config in the content directory sounds like it got rolled back if re-setting-it-up fixed the problem. –  TristanK Jul 28 '12 at 7:29
    
The mystery of why it ever worked remains unsolved. A colleague suggested I delete all traces of WebDAV. This ended up solving the problem. –  Ken Smith Aug 9 '12 at 21:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.