Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have two systems. One acts as Primary/Active and has Internet connection and gets time from NTP server. The second system is Secondary/Passive and has no connection to the external world.

Primary and Secondary are connected on a private network interface eth1. Primary has

  • IP:
  • Subnet:
  • Broadcast:

Secondary has

  • IP:
  • Subnet:
  • Broadcast:

Primary has the following ntp.conf Configuration

driftfile /var/lib/ntp/ntp.drift
statistics loopstats peerstats clockstats
filegen loopstats file loopstats type day enable
filegen peerstats file peerstats type day enable
filegen clockstats file clockstats type day enable
restrict -4 default kod notrap nomodify nopeer noquery
restrict -6 default kod notrap nomodify nopeer noquery
restrict ::1
restrict mask
disable auth

I sync time on Secondary with only ntpdate and do not run ntpd daemon on Secondary. on Secondary I run ntpdate -b -t 4 -p 4 -u (Primary Interface IP) And Ntpd server is running on Primary with the above said configuration.

The time on Secondary is not updated and throws error ntpdate[3636]: no server suitable for synchronization found


share|improve this question
up vote 1 down vote accepted

ntpdate does not read the ntp.conf file.

To synchronize one-time, pass the IP address of the server on the command line:

share|improve this answer
I tried that i still get the same error ntpdate 28 Jul 20:54:03 ntpdate[5452]: no server suitable for synchronization found – Vishu Jul 29 '12 at 3:55
Is there actually an NTP server at that address, and is there a firewall blocking it? – Michael Hampton Jul 29 '12 at 4:05
Ntp Server runs on that is Primary System (CP1) With the above given configuration. and I run ntpdate from that is Secondary or redundant system (CP2). These two Cps are connected over private 1GB ethernet connection. – Vishu Aug 2 '12 at 0:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.