Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to hide boot messages at startup in debian. I saw this link and it was so useful as it said i do this to /etc/init.d/rcS:

exec /etc/init.d/rc S >/dev/null 2>&1

and the result was what I want. but still there are some messages. How can I hide them?

starting portmap daemon ... Already running ..
starting NFS common utilities: statd.
starting enhanced syslogd: rsyslogd.
and ....
share|improve this question
1  
Why do you want this, if something ever breaks or fails on boot you wont know what it is that easy. –  Lucas Kauffman Jul 28 '12 at 11:43
1  
i just do not want the user see the messages ... –  Jush Turner Jul 29 '12 at 7:37
    
And why do you think this will bother the user? –  Lucas Kauffman Jul 29 '12 at 7:41
1  
@Lucas Kauffman: Most non-technical users are intimidated by seeing lots of status text scrolling by. Many desktop Linux distros have this information hidden behind a graphical logo and/or progress bar, but Debian doesn't. I can see why someone would want to hide that if they were deploying Debian-based desktops in their company. –  Starfish Sep 26 '12 at 22:57
    
Exactly. You have to see it from the end user's perspective. –  Austin ''Danger'' Powers Jul 6 '13 at 10:45

2 Answers 2

You can do this by installing and configuring Plymouth. Depending on your graphics card configuration, you might need some additional configuration as documented in the Debian wiki entry for Plymouth. But before you make all of those changes, try the following commands and see if they work for you.

Start by installing the Plymouth package.

apt-get install plymouth

Then edit /etc/default/grub and modify the GRUB_CMDLINE_LINUX_DEFAULT parameter to have the following values.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Finally, update the grub config files.

update-grub2

Now when you boot you will no longer see the diagnostic messages. The messages are supposed to be logged to /var/log/boot.log but it's broken in squeeze. This page claims to have a patch: http://us.generation-nt.com/answer/bug-678982-plymouth-boot-log-not-created-help-207993181.html

Plymouth comes with several boot themes. The default theme is called "text" which will display a blue progress bar at the bottom of the screen during boot. If you'd like to change the boot theme, run the following command with your desired theme name. The -R option is used to rebuild initrd which must be done when changing the theme.

plymouth-set-default-theme -R <theme>

To see a list of available themes, run the following command.

plymouth-set-default-theme --list
share|improve this answer

try changing your colors -- you have the problem of changing every startup script.

the following changes the foreground color to black and the background to black:

echo -e "\033[30m\033[40m Hello World" 

To get yourself back to readable, type 'reset'

so, I would try changing rcS to:

echo -e "\033[30m\033[40m" 
exec /etc/init.d/rc S
reset

That should change the cursor color, and then reset -- the gotcha is if you have an error and the startup script changes the font to yello or red.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.