Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Centos 5.5 server with Xen 3.2 and libvirt for virt-manager installed. Before installed libvirt I have the bridge configuration just like the documentation on Xen says:

xenbr0, eth0 and peth0 interfaces.

After installed libvirt my configuration got:

eth0, peth0 and virbr0

So the virbr0 was added instead of xenbr0, I read the documentation and this is a NAT adaptor for libvirt. So in order to get a bridge adaptor I got this guide:

http://www.howtoforge.com/how-to-install-kvm-and-libvirt-on-centos-6.2-with-bridged-networking

But my peth0 is still up so I presume that xen bridge is still up. Can someone explain me how to proper setup a bridge network interface with Xen and libvirt because with the guide I followed I got a new adaptor called br0 which is the bridge but it has the same MAC address of my eth0 NIC.

I will apreciate any help.

share|improve this question
1  
in case someone needs help with this, first read this post: serverfault.com/questions/42438/… - on the comments say you should use OS native bridging, and in order to disable xen bridge you can use: docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5/html/… –  mongaru Jul 28 '12 at 18:42
add comment

1 Answer

up vote 1 down vote accepted

You can specify that bridge in the /etc/xen/xend-config.sxp file.

Look at the line starting with (network-script. For full options of the xen-bridges look at /etc/xen/scripts/network-bridge.

In your case "bridge= and netdev=" should be sufficient.

But this should only be used if you have only one bridge. For anything else it is recommended to use OS-level configurations.

For a very complex setup with bonds, vlan-trunks and more than 4 bridges I wrote my own init-script on SLES10 - since the OS-level configuration files were not able to do what I wanted.

On more current OSes this should be (almost) no problem.

share|improve this answer
    
Do you have any special ip route setup on the dom0 to allow that the virtual machines can see each other on the same network? I am having trouble with this. –  mongaru Aug 1 '12 at 15:56
    
@mongaru no - nothing special. Check if you have firewalls enabled either on Dom0 or on the DomUs... –  Nils Aug 1 '12 at 20:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.