Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Running a VPS with Centos 6.

If I run ifconfig, the adapter with net is named venet0:0-00

 venet0:0-00  Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
      inet addr:hidden  P-t-P:hidden  Bcast:hidden  Mask:255.255.255.255

So I run this:

iptables -t nat -A POSTROUTING -s 10.8.0.0/24 -o venet0 -j MASQUERADE

But it tells me, iptables: No chain/target/match by that name.

Does anyone see the issue?

I need to allow UDP/TCP traffic for OpeNVPN on many ports, 1194 included. In past usage, the above command works for me.

share|improve this question
add comment

migrated from stackoverflow.com Jul 29 '12 at 1:09

This question came from our site for professional and enthusiast programmers.

1 Answer

Unfortunately this IPtables feature is not virtualized within OpenVZ. This means you can not use it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.