Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to follow this guide here to install Amavis, SpamAssassin + ClamAV...

Things mostly went well but Amavisd would not start...

# service amavisd start
Starting Mail Virus Scanner (amavisd): ERROR: MISSING REQUIRED BASIC MODULES:
BEGIN failed--compilation aborted at /usr/sbin/amavisd line 237.

I installed Unix Syslog at the perl command line...

# perl -MCPAN -e shell
cpan[1]> install Unix::Syslog

But this threw up an error for the path to the BerkeleyDB...

# service amavisd start
Starting Mail Virus Scanner (amavisd): Problem in Amavis::DB or Amavis::DB::SNMP code: Can't locate in @INC (@INC contains: /usr/local/lib/perl5 /usr/local/share/perl5 /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5 /usr/share/perl5) at (eval 82) line 19.
BEGIN failed--compilation aborted at (eval 82) line 19.

The BerkeleyDB files for my distro are installed in...


I did some reading and it seems changing @INC is not so easy - I would need to add "use lib" directly to the perl scripts - modifying Amavis/BerkeleyDB doesn't seem the sensible or correct approach. So I tried moving the BerkelyDB files to...


Which is in the @INC path. This nearly worked but now I get...

# service amavisd start
Starting Mail Virus Scanner (amavisd): /usr/bin/perl: symbol lookup error: /usr/share/perl5/vendor_perl/auto/BerkeleyDB/ undefined symbol: Perl_Tstack_sp_ptr

I'm sure I'm going the wrong route here. I'm a perl n00b but it seems odd that yum installs places the BerkeleyDB files in a place that perl cant access them. Hoping someone can cut through my mess.

Many thanks!

share|improve this question

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.