Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

So, I've been trying to get a kickstart install with Red Hat Enterprise Linux 6.2 to work, using the package repo on the DVD. As such, I've tried using the following line in my ks.cfg:

 repo --name="Red Hat Enterprise Linux"  --baseurl=cdrom:sr0 --cost=100

However, that doesn't seem to work. The installer can't find the repo, and the install fails. Have I got the repo syntax wrong?

UPDATE: It looks like I've got a more serious problem. Even if I boot without using the kickstart file, the installer reports that there is a problem with the generation of my install tree. I'm going to go ahead and run this install manually now, but it is a bummer that I can't get kickstart to work. :(

share|improve this question
    
Did you say Red Hat 6.2? That's ancient. I hope you meant Red Hat Enterprise Linux 6.2. –  Michael Hampton Jul 30 '12 at 2:45
    
Well, the repo command uses "Red Hat Enterprise Linux", and the question tagged with RHEL6, not Red Hat...wasn't aware that it'd be a block to answering the question. –  Vishal Kotcherlakota Aug 6 '12 at 17:27

1 Answer 1

I hope you're still working on this, because I ran into something similar when I was building my own iso. You need to set the baseurl to file://mnt/source to load from the repository on the DVD, e.g.

repo --name="Scientific Linux" --baseurl=file:///mnt/source --cost=100

When kickstart is able to find the repo, it will also resolve your install tree error. At least, it did for me.

Best of luck

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.