Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to make it so that Internet Explorer starts with my companies Intranet page every time a user logs on to a Terminal Server, but I can't get it to work.

I am using Windows Server 2003 and the 'Run these programs at user logon' key and adding the following command, but it appears that it is being ignored by the GP (not listed in gpresult \v at all).

"c:\Program Files\Internet Explorer\iexplore.exe"
"c:\Program Files\Internet Explorer\iexplore.exe" http://dynedrewnett
iexplore http://dynedrewnett

I also have checked the Registry for the key that MS say should contain the prograns to run at logon, but the key does not exist -

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer\Run

Does anybody know why this is not working? Thanks.

share|improve this question
    
You say it doesn't get listed with gpresult... have you checked that replication is working? Have you tried gpresult /force? –  Mathias R. Jessen Jul 30 '12 at 10:40
    
You have created a custom adm template? –  Greg Askew Jul 30 '12 at 10:42
    
In what sense? I have a DC that holds our GPs and 4 Terminal Servers, so not sure what replication I should have (sorry, not very experienced with GP)? Is there a way I can check things like the last edit time of a GP that has been applied, to make sure that my changes are actually being applied (or that at least an attempt is being made to apply them)? –  David Gard Jul 30 '12 at 10:48

1 Answer 1

up vote 1 down vote accepted

Although it could be something else since you mention that gpresult doesn't show the setting, have a look at the below.

From here

Unless the file is located in the %Systemroot% directory, you must specify the fully qualified path to the file.

Try supplying the full path to iexplore.exe

Other things to check:

  • Ensure that the GPO is applied to an OU that contains your user accounts, or use Loopback Policy processing.
  • If you only recently made the change, ensure that the policy has been updated on the server you're testing on using gpupdate
share|improve this answer
    
Thanks @ChrisMcKeown. I have edited as above (to see if it picks anything up at all) and I'm still not getting anything. –  David Gard Jul 30 '12 at 10:37
    
Added some additional things to check. –  Chris McKeown Jul 30 '12 at 10:43
    
Thaks again. GP is being applied, just not the 'Run these programs at user logon' key. And have been logging off/on as well as running GPupdate, but sadly to no avail. –  David Gard Jul 30 '12 at 10:51
    
And your user accounts? Are they definitely located somewhere under the OU where you have applied the policy? –  Chris McKeown Jul 30 '12 at 10:53
    
^^ I take that back, GPupdate is actually adding the programs to the Registry key that I specified above, but not running anything at that time. Logging off and on then opens IE at log on (all 3 entries work). –  David Gard Jul 30 '12 at 10:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.