Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've just gotten around to analyzing our log files. After banging my head with log parser and several other 'analyzer' tools I came to realize that my log files appear to be missing their header section. There are no #Software, #Version, #Date nor #Fields directives - it just starts right into the log data. I've looked closely at the IIS logging dialog and don't see a bool there to 'enable header' or anything...

I'm using Windows Server 2008 (x64) running IIS version 7.0.6000. Thanks.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Make sure the log file format has been set to W3C and not IIS or NCSA. In both of those instances, the log files have no header.

If your log files are in W3C format, the log filenames will begin with u_ex by default. For IIS format the prefix is u_in and for NCSA the prefix is u_nc

IIS Log file Configuration

share|improve this answer
    
I was viewing the logging settings of the IIS root value (machine) - when I then selected the "Default Web Site" entry - I discovered entirely different logging settings. My log files are prefixed with u_nc. Thanks! –  valveLondon Jul 31 '12 at 15:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.