Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I upgraded my MySQL server from 5.1 to 5.5 on CentOS (with 2 cores and 2GB RAM). With my old my.cnf the mysql service doesn't start anymore (complains about a PID file), so I use an almost empty my.cnf now.

Now I get iowait warnings all the time. This happens even when only trying the application with 1 user.

Anybody has any tips why this happens?

The innodb database is about 500 MB in total, and uses quite large temporary tables in some stored procedures.

I'm searching for the optimal settings of my.cnf , since I suspect that I should change some default values, but which ones...?

share|improve this question
    
take a look at this question serverfault.com/questions/377552/… and answers –  pQd Jul 31 '12 at 14:13

1 Answer 1

  1. Need old and new my.cnf (pastebin.com)
  2. Please specify distro and clarify upgrade process
  3. Copy default 5.5 my.cnf provided by your upgrade package
  4. Copy all the entries, except path, plugin or innodb related ones
  5. If you have Innodb entries in old my.cnf - goto 0
  6. use mysql_upgrade script
  7. need logs
  8. it's hard to tell why do you have iowait - because of low memory usage or disk, if things didn't change - just copy optimization settings - should work!
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.