Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am using fetchmial. Below is my configuration. I want the retrieved emails to be sent to my gmail address. But I encountered an error below. Could someone help me with this? Thank you in advance.

configuration: poll with protocol IMAP user '' password 'passwd' smtpname smtphost

the error: fetchmail: SMTP< 530 5.7.0 Must issue a STARTTLS command first. pe8sm1120100pbc.76 fetchmail: SMTP error: 530 5.7.0 Must issue a STARTTLS command first. pe8sm1120100pbc.76 SMTP server requires STARTTLS, keeping message.

share|improve this question

2 Answers 2

Google Mail's SMTP server is requiring you to connect with TLS, but you have configured fetchmail to never use TLS.

Check your fetchmail command line and configuration file for sslproto and make sure it is set to TLS1.

On the command line:

--sslproto TLS1

In the conf file:

sslproto TLS1

See the fetchmail documentation for more on configuring SSL/TLS.

share|improve this answer
Thank you for your answer. I agree with you. But it still gives me the error after I add sslproto TLS1 in conf file. Do I need a client side certificate? –  user1500178 Aug 2 '12 at 20:59

You must get gmails certs first:

openssl s_client -connect -showcerts

The command above will return the certificate from Google's Gmail

You need to copy the certificate part, which is everything between the "BEGIN CERTIFICATE" part and "END CERTIFICATE" part, and save this to a file.

save it to /ssl/certs/.certs


set daemon 90
set syslog
set postmaster serverusername
poll with proto POP3 and options no dns 
     user '' with pass "****"  is 'username' here options ssl sslcertck  sslcertpath '/ssl/certs/.certs' 
     smtphost localhost    
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.