Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a centos 5.3 64 bit XEN guest running on a 64 bit centos 5.3 XEN host. I'm trying to get sshfs installed on it but am running into some problems. I've installed fuse and fuse-sshfs from rpmforge (using yum). But whenever I try to mount a directory I get the following error:

fuse: device not found, try 'modprobe fuse' first

Running modprobe fuse I get:

FATAL: Module fuse not found.

I've restarted the guest but I still get the same error

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Did you install the dkms and dkms-fuse package? That is probably what you are missing. The fuse package just has the userspace tools, so I am not sure why it does not depend on dkms-fuse.

DKMS is a system for automatically rebuilding external kernel modules when your kernel is updated. It is also used for some nvidia kernel modules. You will also need to make sure that the dkms_autoinstaller and fuse services are started at runtime. The fuse service (last time I checked) doesn't properly support chkconfig, so you have to manually create the symlink in /etc/rc5.d (or whatever runlevel you want).

share|improve this answer
    
nope I didn't have that installed. Funny that it wasn't marked as a dependency for the fuse package. –  Chris Gow Jul 15 '09 at 23:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.