Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have geminabox running on port 9292 using the "thin" rack web server.

Here's my nginx config for the virtual host in sites-available:

server {
  server_name        gems.mydomain.net ;

  proxy_set_header Host $http_host;
  location / {
    proxy_pass http://127.0.0.1:9292;
  }

  error_log         /var/log/nginx/geminabox-error.log;
  access_log        /var/log/nginx/geminabox-access.log;
}

If I access the host using http://gems.mydomain.net I get the geminabox main page. But if I go through nginx on port 80, it redirects to /index.html. Sinatra returns a 404.

How can I get nginx to not try to redirect to index.html?

share|improve this question
    
Based on what you have provided, there is no reason for nginx to be doing that. Debug logs would be a good first step to diagnose the problem. –  womble Aug 2 '12 at 3:42
    
I went to turn on the debug logging ... and the behavior went away, back to what was expected. I guess it will remain a mystery. –  Mojo Aug 2 '12 at 4:23
    
Smells like you didn't reload the config after making the initial set of changes. –  womble Aug 2 '12 at 10:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.