Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I installed Solaris 10 on my machine, but noticed that apache-tomcat is in maintenance state.

I tried these commands but of no use:

svcadm clear apache-tomcat
svcadm enable apache-tomcat

The logs just say this:

Failed to start Tomcat...

[ Aug  2 01:12:10 Method "start" exited with status 1 ]

Can someone please help me troubleshoot the issue?

share|improve this question
    
Got logs? Probably catalina.out? –  Shane Madden Aug 2 '12 at 5:25
    
I am not able to find catalina.out. –  cppcoder Aug 2 '12 at 5:34

1 Answer 1

Review the logs for the FRMI in /var/svc/log/. To see where the logs are, run the following;

You should see output similar to the following;

server$ svcs -xv svc:/system/system-log:default | grep "/var/svc/log"
   See: /var/svc/log/system-system-log:default.log
server$ 

That will tell you why SMF is putting the service in maintenance-mode.

EDIT: Just saw your update. Okay, now to find out what the SMF manifest is doing when it's called with the start argument.

Look in /var/svc/manifest for a *.xml that has tomcat in the name and read the script and find out what it does.

Perhaps it's unable to create a log file due to a lack of permissions and that is what's causing the start to fail.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.