Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a bind DNS where I have installed SAMBA and made it a BDC. I plan to promote it to PDC and take out the Win2003 AD server to replace it with Samba.

Bind is installed on that same server as Samba and internal resolving work fine. However forwarding to the external DNS server for some reason does now work.

dig @8.8.8.8 google.com yields the correct output so I expect no connection issues.

The OS is Ubuntu (2.6.32) and Bind 9.7.3

What I have tried so far,

1) Adding to named.conf.options

recursion yes;
    allow-recursion { localhost; };

2) Adding to named.conf.options

recursion yes;
    allow-recursion { localhost; 10.10.14.241; };

3) Adding to named.conf.local

zone "." {
        type hint;
        file "/etc/bind/root_servers.hosts";
        };

4) Adding to named.conf.options

forwarders {
            8.8.8.8
            };

5) Adding to named.conf.local where the zone info is saved

zone "DOMAIN.COM" {
        type master;
        file "/var/lib/bind/DOMAIN.COM.hosts";
        check-names ignore;
        forwarders {
        8.8.8.8;
        };
        };

None have worked so far,

Please advice.

Thanks.

share|improve this question
    
What system are you querying the server from? What response do you get? –  Shane Madden Aug 3 '12 at 5:53
add comment

1 Answer 1

I had a similar issue with the latest ubuntu server version (12.04 LTS). The problem was that the dnssec-validation option in /etc7bind/named.conf.options was set to auto. I changed it to no:

dnssec-validation no;

This solved my problem. In fact dnssec tries to validate the forwarder, and this was failling for my forwarder. You can check in /var/log/syslog for an DNS error similar to:

Aug 31 19:38:06 srv1 named[3208]: error (no valid RRSIG) resolving 'ch/DS/IN': 192.168.1.1#53

(my forwarder is 192.168.1.1).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.