Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to debug a simple web service. I have IIS 7 installed on my development machine (Windows 7), and have installed the web service. I can access it from my development machine, but not from any other machine in the local network.
I opened the firewall to HTTP access, and I can access the default website from other machines, so it is not the firewall.
What security settings should I look at to try to allow devices on the LAN to access the web service?

share|improve this question
1  
How are you accessing it from other machines? You're not using http://localhost are you? Also, what error / response code are you getting? –  squillman Aug 2 '12 at 14:30
    
I'm using the LAN IP address: 192.168.2.102. Again, just entering that address gives me the default IIS 7 web page. Adding 192.168.2.102:8080/api/results (which works on the local machine) gets no response. Wireshark shows that the client is sending a TCP SYN frame, and there is no response. Do I have to open something besides HTTP in the firewall? –  Aharon Manne Aug 2 '12 at 14:44
    
Turned off the firewall entirely, and still no joy. –  Aharon Manne Aug 2 '12 at 14:46
    
Is your web service running in a different actual web site than the default website? –  squillman Aug 2 '12 at 14:50
    
Yes it is. It is a separate web site under IIS –  Aharon Manne Aug 2 '12 at 14:52
show 4 more comments

3 Answers

Check the bindings on the web site your web service is running under and make sure it has a binding for 192.168.2.102 on port 8080. Also, make sure your default web site does not have a binding for 192.168.2.102 on port 8080. In all of that, make sure you don't have any wildcard bindings on the default web site that would match 192.168.2.102 on port 8080.

share|improve this answer
    
The default website has bindings for 808:* and *. Would these interfere? I will remove them and see what happens. –  Aharon Manne Aug 2 '12 at 15:03
    
Removed those bindings, and still no joy. –  Aharon Manne Aug 2 '12 at 15:04
    
808:* will not match 8080. Is the other one (*) for port 80? If so, then that one should be fine to keep as well. –  squillman Aug 2 '12 at 15:06
    
Did you check the bindings on the other site to make sure there is an http binding for port 8080? –  squillman Aug 2 '12 at 15:06
    
The binding for my web service is 192.168.2.102:8080. I disabled the default website, and that didn't change anything. –  Aharon Manne Aug 2 '12 at 15:15
show 10 more comments

This isn't an answer yet, but I couldn't figure out how to add screenshots to a comment. Default website bindings (works).
Default
Web service binding (works only locally):

share|improve this answer
    
I was pretty sure that the issue was permissions, so I did a point by point comparison of the default website permissions with my web service. That led me to add IIS_IUSRS to the list of users, but still no joy. @squillman, if you have any more ideas, I'd be glad to hear about them. –  Aharon Manne Aug 7 '12 at 10:46
    
Further, comparison if ASP.NET authorization and IIS authentication did not yield any differences between the site that responds, and the site that doesn't. I still think it's a security issue. –  Aharon Manne Aug 7 '12 at 10:53
    
Both the default website and the webservice use an application pool that I defined. The application pool defines the Identity as NetworkService. The default site does not inclue permissions for Network Service, but my webservice does. Nonetheless, it is possible to access the default site, but not my webservice. –  Aharon Manne Aug 13 '12 at 10:31
add comment

In the end, it was the firewall. In other words, turning off the firewall makes the service available. For my test purposes, that is good enough.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.