Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I returned from vacation to find a "helpful" intern had installed some Mandriva 2011.0 updates on a linux server, and he had updated Cygwin to 1.7.16 on a Windows XP machine.

Prior to the updates, I could ssh from cygwin to the linux box using something like ssh user@johnny5 and I could login using my Linux user/pass. (sshd is configured for RSA public key authentication using local credentials.)

Now, when I attempt to login as before, I get:

$ ssh user@johnny5

Windows Authentication

Password:

Domain:

Nothing appears to have changed in sshd_config, so I have no clue as to what broke my usual login method. (I'm tentatively blaming something on the Linux side - but I suppose it could have been the Cygwin update).

Any suggestions? Thanks...

share|improve this question
    
Make the intern fix it? –  Michael Hampton Aug 2 '12 at 19:30
    
@MichaelHampton yeah, that was my first thought. (Didn't work) :) –  Throwback1986 Aug 2 '12 at 20:59
add comment

1 Answer

up vote 1 down vote accepted

Tell ssh to go verbose and force the authentication method. E.g.,

ssh -v -o ChallengeResponseAuthentication=yes -o PasswordAuthentication=no user@johnny5

The verbosity might tell you what's causing the problem. You may have to disable another method of authentication with another -o

share|improve this answer
    
As much as I want to blame the intern, it looks like there was some shuffling of IP addresses. My /etc/hosts entry for johnny5 no longer pointed to my Linux box. Instead the IP address had been changed to actually point to a Windows box running sshd. I hadn't considered that IT may have been the culprit. This answer spurred me in the right direction. Thanks! –  Throwback1986 Aug 2 '12 at 21:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.