Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm running Windows Server 2008 and Windows XP clients attached to the domain.

The local user has a background image specified, which I am trying to override with a GPO.

I attempting to set the desktop wallpaper by using a GPO to copy the image file to the local workstation in computer configuration\preferences\files

action: create

source file: \\mydomain.local\NETLOGON\wallpaper\background.bmp

destination file: c:\scripts\wallpaper\background.bmp

Then, setting the wallpaper in user configuration\administrative templates\desktop\desktop with the setting desktop wallpaper

wallpaper name: C:\scripts\wallpaper\background.bmp

wallpaper style: centered

I am able to see the default wallpaper briefly after logging in, but then it disappears and I'm left with a blank background.

The image file is available on the server, and is successfully copied to the local workstation.

The Client side extensions update is installed on the workstation and other user-based GPO settings are working.

Here are all the settings in the desktop GPO: Desktop GPO settings Desktop GPO settings

Am I missing something?

share|improve this question
1  
As a test, does the GPO work if you point it at a local .BMP file that hasn't been copied using preference settings and picked up using the CSE? Second question, are you performing the client test directly on the PC, or via RDP? –  Simon Catlin Aug 2 '12 at 22:22
    
I am using the PC directly. RDP is not in use. –  Force Flow Aug 3 '12 at 1:11
    
I copied the .BMP file manually to C:\documents and settings\all users\documents\test.bmp, set the wallpaper GPO to that location, ran the gpupdate /force command, and rebooted. The background was still blank. –  Force Flow Aug 6 '12 at 21:11

3 Answers 3

@Simon-catlin has good hints, and here's a larger list of things to check:

Note if you have to test this via RDP, ensure the RDP session is set to max fidelity (the desktop background is checked or you'll never see it).

  1. When having a GPO issue, you need to only troubleshoot that issue. Just in the screenshots you have dozens set, but you first need to just test one: setting the background. Move the computer to a OU outside of all other GPO's and create a test GPO to walk though this, which will help you find what the hangup is: permissions, conflicting GPO's, etc.
  2. Once you've verified you can set the bmp to a local default file built into XP, then manually copy the one you want over, and try setting it.
  3. Once that works, then test the GPP. Note that you'll need to use the file copy in the Computer GPP so it copies before the user logs in.

Lastly, it may take multiple user logins to see it. With some GPO's, especially in XP, they are set on first login, but don't take affect till 2nd login. Often you'll see info about that in event logs.

share|improve this answer
    
RDP is not the issue. I have direct access to the workstation. I attempted using just the one setting as suggested, but with no success. The event logs show no errors. I copied the .BMP file manually from the server to another location on the workstation (and set the GPO's wallpaper path to that), but was unsuccessful. I am still unclear where the problem is as all I seem to be getting are negative results. –  Force Flow Aug 6 '12 at 21:13
    
So you moved a test workstation out of the way of all GPO's, created a new one with only one setting to set a different BMP on the C: and that didn't even work? –  Bret Fisher Aug 7 '12 at 1:50

I suspect this is happening because the user is using software based wallpaper rather than a static image. In such a case the policy wallpaper would display until such time as the software controlling the wallpaper locally starts up, at which time there is a conflict, with apparently neither one winning. Check what's being run at user logon on that machine. Many screen saver programs will also set the wallpaper.

share|improve this answer
    
There's no extra software in play here. –  Force Flow Aug 3 '12 at 1:09
up vote 0 down vote accepted

As it turned out, the problem was two-fold.

First, it was a file permissions issue. When the file is copied from the server to the workstation using the "computer configuration" section of group policy, the copied file only gets assigned permissions for domain administrators.

So, following this technet article, I assigned domain users to the containing folder of c:\scripts with inheritable permissions using computer configuration\policies\windows settings\security settings\file system

Second, two additional Desktop preferences needed to be set in group policy. Under user configuration\administrative templates\desktop\desktop: Enable Active Desktop needs to be enabled and Disable Active Desktop needs to be disabled.

After logging out and logging back in with all that configured, the desktop background image was able to appear.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.