Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to reinstall CouchDB on my machine, but I need to remove it fully first. I removed both couchdb and couchdb-bin packages using

sudo apt-get remove couchdb
sudo apt-get purge couchdb

However, when i perform

curl -X GET http://localhost:5984

I still get


...and the configurations of the old installation is still intact (when I query the /_config API), which I don't want.

What am I doing wrong?

Yes, the question is similar to this one, but only in that it is about fully removing this package. My situation is different, and I've tried all the suggestions there but they haven't worked for me.


share|improve this question
up vote 3 down vote accepted

You simple need to kill the process. Use this :

sudo killall -9 couchdb
sudo killall -9 beam

Simply restarting will also do the trick, but just in case you are not at a liberty to restart you have the above commands at hand.

share|improve this answer
that appears to have done it, thanks! – Harlo Holmes Aug 3 '12 at 8:34

You removed the packages but the process is still running.
You need to stop the process.
The init script is now probably removed too, so just kill the couchDB process.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.