Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an issue with a mount point that was previously configured. It shows the folder, but the mount is missing and holds "?" values for size, permissions, etc.

So I tried to remount using cifs and the same command from before:

mount -t cifs //nas.domain.local/share /mnt/archive

But I get the error:

Host is down.

If I ping the domain or IP I get a proper resolution and I also connected using smbclient without issue

 ping nas.domain.local
 ping ip
 smbclient //nas.domain.local/share

I looked around, but cant find a solid answer. Any thoughts?

share|improve this question
    
do a nslookup nas.domain.local does it equal the ip you pinged? –  tony roth Aug 3 '12 at 17:19
    
Yes, the IP returned is accurate. I can access the web interface of the NAS using the IP and domain as well. I can access the data on my laptop using either the domain or IP so it seems there is some other issue at play here –  Kevin Aug 3 '12 at 17:28
4  
Add the --verbose switch to your mount command, post any errors/results that seem relevant. –  Zoredache Aug 3 '12 at 17:55
    
Thanks Zoredache. The previous mount never fully unmounted itself. Once I finally got the mounted location completely removed (quite the fight) it then allowed me to reestablish the mount. I'm not sure why this happened as of yet. –  Kevin Aug 21 '12 at 21:15
add comment

3 Answers

up vote 1 down vote accepted

I typically use this type of command to mount a cifs/smb share.

mount -t cifs -o rw,netbiosname=nasserver1,credentials=/etc/user_credentials.txt //192.168.1.11/someshare /mnt

the credentials file looks like so:

username=mydomain\user1
password=somepass

This can also be adapted to an automount setup so the mounting/unmounting can be handled by the system automatically via autofs.

share|improve this answer
add comment

Sorry if this is a late response (I realise it's an old thread), however I have just discovered there is another possible reason why mount.cifs would say the host is down.

I have an antivirus with a firewall and even though I set it explicitly to allow "windows file and print sharing" -- a predefined rule, it was still blocking connections. I had that proven by disabling the firewall temporarily. Hope this helps someone, host is down might not mean it's not responding to pings, but could mean it's not responding to authentication attempts.

share|improve this answer
add comment

Is the service even running on the remote server. It is a Linux or Windows Server? If it is Linux... verify that the service is running. Make sure no changes have been done to the firewall...

If it is windows... then you might consider a reboot...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.